Calendar doesn't connect

Dec 2, 2009 at 10:12 PM

I have Windows 7 on two machines.  On one, everything works fine.  On the other the calendar doesn't download the data (both reference the same calendar).  In previous versions I noticed when coming out of standby I would get an error, but it would eventually download.  Now, the error messages are turned off and it never downloads. 


On the computer where it works, I have Mcafee loaded.  On the one that it doesn't, I have Microsoft Security Essentials.  I looked in MSE to ensure the gadget is not blocked.  Other that that I don't think there are any other major differences.  Obviously both use the same router/modem.


Any ideas what may be causing the issue?

Dec 4, 2009 at 10:13 AM

This is weird. Actually I didn't turn off the error messages. They should appear when you start the gadget, commit the settings dialog or when your computer is comming out of standby (but some errors are suppressed - e.g. when your offline). I'll try to install MSE and will see, if it influences the gadget. Otherwise I can make a special build for you showing more error messages... Thanks for feedback!

Dec 4, 2009 at 10:33 AM

So, I've just install MSE and no problems occurred to me :-( What calendar service are you using - WL, Google? What do you see on the not working gadget - is there a "no events" notice (in compact view) or something else (is the calendar just empty)?

Dec 4, 2009 at 9:57 PM

Yea, it is weird.

I am using Windows Live Calendar.  No events in compact or full view.  I also looked in windows firewall, didn't notice any rules blocking.

I can send the link to my calendar for you to test, but as I said, It works fine from other machine.

OK I just uninstalled the latest version you have oposted on download 25 Nov 2009, and installed a previous version (not sure whic one, but it does have the weblink - I downloaded it 11/15 and it is 42K) and it loads.  Hasn't run long enough to tell if I get the error message coming out of standby.

Let me know what to try next.


Dec 5, 2009 at 8:27 AM

I've just uploaded an alternative version of the gadget, it's called WLCalendar.Debug.Gadget and you can find it in download section. There is enabled showing of all error messages and slightly modified the way how ics files are downloaded. I hope, it'll give us more information. Thanks a lot for collaboration! Zbynek

Dec 5, 2009 at 1:08 PM

Could not load Calendar (0): then the Web address starting on next line.

This is the same error message I get with the earlier version.  The new version (from 25 Nov) doesn't give any error message.




Dec 5, 2009 at 5:39 PM

Hm, I suppressed that error because it makes no sense (the errors are the codes of HTTP protocol and those start at number 100). So it’s highly probable, that there will be a problem on your side (firewall or something like that). I'll do more research and let you know, if I find the solution.

Dec 5, 2009 at 8:32 PM

Unfortunately I didn't find any exact explanation of that error yet, but I found a theoretical solution. In my opinion I don't believe, that it'll work, but you can try it - just download the debug version again (I've updated it just before a few minutes).

Dec 5, 2009 at 9:02 PM

I tried the new debugger version, still the same error.  So it may be a rule in Winsows firewall is what you are saying?  Shouldn't be hardware (on network side as I have no problem with other computer.

Let me know what to do next.


Dec 5, 2009 at 10:19 PM

I tried turning windows firewall off, still have the same error message.


Dec 6, 2009 at 9:32 AM

Unfortunatley I haven't any further ideas for now. Both of those computers are in the same network? If it's so, than there must be something wrong in configuration of the computer, but what...

  1. You can try open the settings dialog, copy the url of your calendar and paste it in the internet browser - than should appear the dialog for a download of the ics file. If not, than the url is wrong (but it seems to me not much probable).
  2. Than you can try to run the sidebar process as administrator and see, if it helps.
  3. The last thing you can do is to enable script debugging on you machine - you can enable it in the Internet Options (the dialog can be run from IE), on the tab called Advanced and in the section Browsing uncheck both options called "Disable script debugging..." . Then restart the gadget and if there is any error in source code, than you'll get the notification.

The downloading of the ical calendars works exactly the same way as ajax on the websites. If you don't have any problems with ajax (if facebook works on both of your computers), then you shouldn't have any problems with gadget. I'll keep working on it...

Dec 6, 2009 at 6:11 PM

Ok, When I do #1, I do get the save dialog box, but I need to click on the yellow security bar that pops up on top (the other two computers do the same thing.

On #2, Can't see how to run as Administrato, but when I click properties, there is a block that says this file might be blocked because it came from another computer, so I disable that and it still doesn't load the calendar.

For #3, I enabled both script debuggers and reloaded gadget, doesn't load calendar and no notification....



Dec 6, 2009 at 7:00 PM

I guess the problem is in the yellow security bar. If I paste my ical url in the IE, I'll get instantly the download dialog without any security bar. Unfortunately I can't simulate your situation. I tried to increase my internet security level which prevented IE to download the ics file (but I got an error message instead of the yellow security bar), however the gadget still worked. Try to play a little bit with your internet security settings (the same Internet Options dialog as in the point #3) or try to right-click on the yellow security bar if there isn't any option like "always trust..." or something like that.

Dec 6, 2009 at 8:12 PM

Driving me nuts....

I got the security bar to go away, still have the problem

I checked all my Internet settings (security, privacy, content through advanced - all of them) against another windows 7 machine that the gadget works on.   The only setting that was different was I needed to check http 1.1 through proxy connections under HTTP 1.1.  Still no luck.

Going to go through all the rules in Windows firewall and MSE next.

I did note I sometimes got connections wiith earlier versions, but the new versions won't connect at all....did any of the calendar download code get changed?




Dec 6, 2009 at 8:26 PM

That's the weirdest, principaly I didn't change anything (only added same http request headers). I'll make a new release right now (with those headers disabled) and we'll see (by the way, in the release will be a new feature - it displays a decent timeline under the running events).

Dec 6, 2009 at 8:29 PM

Found it.

I have two inbound rules for internet explorer on the machine where the gadget doesn't work.  When I disabled the rules, the gadget starts working.

I didn't put the rules there, something else must have.  I can copy the rules and send them to you if you like.



Dec 6, 2009 at 8:34 PM

Great! So the http headers are ok... I'll be thankful, if you put here the rules... Thank you! (In this case I'll postpone the announced release until I solve few more things.)

Dec 6, 2009 at 8:43 PM

OK, here are the rules (weird because they are 'allow' rules)

First rule:

Name - Internet explorer

Group - Blank

Profile - Private

Enabled - No

Action - Allow

Override - No

Program - C:\program files (x86)\internet explorer\iexplore.exe

Local address - Any

Remote address - Any

Protocol - UDP

Local Port - Any

Remote port - Any

Allowed users - Any

Allowed computers - Any

Rule #2 is the same except the Protocol is TCP







Dec 6, 2009 at 8:51 PM

Hm, I wouldn't say, that those rules could block the gadget. They even wasn't enabled (I assume it means, that they are in use) and you wrote upper, that you tried to disable the firewall. Anyway I'm glad, that it works now.

Dec 6, 2009 at 8:57 PM

When they are enabled, the gadget doesn't work.  When I disable them the gadget works....yea, weird, expecially since they are inbound 'allow' rules.

Not sure why disabling the firewall didn't turn off the rules....

Will keep monitoring and let you know if anything else developes.

Would like to know if someone out there can explain why these rules would cause the problem.


Dec 7, 2009 at 9:10 PM

Yea, so it is doing it again.  Same error (0).  Rules are turned off still, so that explains whay it didn't make sense.

Just funny how it started working when I disabled the rules - must have been a coincidence.

So back to the drawing board....


Dec 12, 2009 at 4:13 PM

Still getting 'random' 0 Messages.

So I tried loading US Holidays.  Worked initially, but now shows 404 error.  I can see the holidays fine from my Windows Live page.


Dec 14, 2009 at 4:28 PM

So US Holidays worked? I thought that the gadget is not able to download anything. Don't worry about 404 error, it happens sometimes with this "built-in" calendars (it's probably an issue in live calendar service - one month ago it wasn't happening). Have you tried to create a new calendar and use it with gadget (maybe is your problem somehow connected only with the one calendar you are using)?

Dec 26, 2009 at 4:19 PM

Hi, I've released a new version of the gadget. Please let me know, if it works now. Thanks..

Dec 26, 2009 at 4:31 PM

Ok, working great now! (I am the same guy from the feature request discussion).

Thanks, looking good!!