ics doesn't work

Jun 24, 2011 at 5:10 PM

Hi, try to load gadget since weeks, but after copy of ics-link into calendar, calendar says "loading", but nothing happens! Thks for yr help! Michael

Jul 6, 2011 at 12:23 AM

I also have a similar issue but only on my laptop. For whatever reason, my computer at work (running Windows 7 enterprise 64bit) immediately loaded my google calendar with no hesitation. Here at home on my laptop (same operating system), which is the computer I really need my calendar on, the gadget says "no events to display" but my calendar is full.

Any suggestions? I do have a firewall running, but my home security is much lower than my office's security. The only big difference I can see is that the laptop is wirelessly connected to the internet vs. my wired connection at work.

In both cases I used the same private ICAL link from Google Calendar.

Any help would be appreciated.

Aug 7, 2011 at 9:03 PM

Hi all,

to RobinL: this is weird. Please try to put the link of your calendar into browser and download the ics file. Than you can see whether the file is empty or contains all your events. In case it contains all the events it is downloaded properly and the gadget should work and so the problem will be somewhere else. Please let me know whtether you can download the file...

to Meistermann: it is hard to guess what's the issue. Could you please send me a link of sample calendar which behaves the same way? It would be very helpful...

Thanks a lot!


Aug 8, 2011 at 1:00 PM

Hello! I have a very odd report for you - I did some reading on other Google Calendar desktop aps, and it turns out that IE9 is the issue. I uninstalled the windows update that included IE9 and returned to IE8 and suddenly ALL of my desktop gadgets work wonderful. I have no idea what it is about IE9 that kills a lot of the gadgets, but since I never use IE anyway, I am content to leave it at 8. Thanks for your help - if anyone else has problems with getting a Gadget to connect properly, try that solution. :)

Sep 1, 2011 at 1:19 AM

I have problems with WLCG for weeks...

I am used to use google calender... so I copied all ICAL Links into WLCG. Everything was working fine except the application sidebar.exe began to crash 4-5 times a day. Registry settings ShowScriptErrors didn't work...

I tried something new... locale ICS files. I pimped Thunderbird with Lightning, Provider for Google Kalender and Automatic Export to write ICS file to an local HDD folder. Everything worked fine... until 0:00 am --> None of my Calenders were found... but ICS files are present and not empty. --> Reading my dates and tasks is no problem, but if I switch to next day it will show up errors again. Finally sidbar crashes after a while  :(

After restart everything works like charm, but I'm afraid that it will happen again next day.

By the way... I didn't shutdown,hybernate or anything like this


Win7 32 Bit, IE 9

Oct 9, 2011 at 5:29 PM

That's very interesting issue oOnikiOo, would be possible to send me a copy of your local ics file so I'll be able to do some tests? It seems to me like it is not a bug in the gadget itself but you have some application in your system interfering with the sidebar process but this is just a guess...

Oct 11, 2011 at 1:39 AM


My other Gadgets: CoreTemp and GPU Observer

Oct 13, 2011 at 10:07 AM

Thank you for the testing calendar. I've done some tests but unfortunately I haven't notice any problems. The gadget keeps running no matter what (hibernation, sleep mode, running of various applications). I think there is no such bug in the gadget the problems you’re experiencing seem to be specific to your computer. I’m afraid I’m not able to solve it for you…

Oct 14, 2011 at 1:40 AM

Sorry, I deactivated the Gadget on Sep. 2. because of annoying crashes. Reactivated it yesterday and now without any errors. I did't change my System except OS Updates and AntivirsProgram (FreeAV AntiVir to Avast).

http://support.microsoft.com/?kbid=2564958 Security Update KB2564958 12.10.2011
http://support.microsoft.com/?kbid=2567053 Security Update KB2567053 12.10.2011
http://support.microsoft.com/?kbid=2572077 Security Update KB2572077 12.10.2011
http://support.microsoft.com/?kbid=2579686 Security Update KB2579686 12.10.2011
http://support.microsoft.com/?kbid=2586448 Security Update KB2586448 12.10.2011
http://support.microsoft.com/?kbid=2570947 Security Update KB2570947 15.09.2011
http://support.microsoft.com/?kbid=2616676 Update KB2616676 15.09.2011
http://support.microsoft.com/?kbid=2607712 Update KB2607712 08.09.2011

Maybe one of them made it work ??

Oct 14, 2011 at 8:20 AM

Maybe :-) It's hard to say whether those updates really helped or which one of them it was. But I'm very glad it works for you now. Maybe the most probable cause is the antivirus since those programs are scanning the scripts running in the background and so may interfer with the scripts runnning in gadget.

Nov 28, 2011 at 7:36 PM

I am running win7 64 on three computers, AVG free on 2 and AVG pay on one. It worked great on the two with free AVG the pay one is stuck saying "loading". I do not know if hte version of AVG is the issue or something else. I tried reloading the program, recreating the ical files etc, still stuck. Love the gaget, need to get it working.

Any help is very appreciated..


Dec 4, 2011 at 5:25 PM

Hi, I've just released a new version of the gadget, please feel free to download it and let me know, if the problem still remains. Thanks a lot!