[object Error] & published Calendar from Outlook 2010

Mar 5, 2011 at 12:41 PM

I published Calendar in web from Outlook 2010 with public access and I can open it by URL in Outlook 2010 but in Windows Live Calendar Gadget i get error [object Error] when trying open it by this URL

webcals://calendars.office.microsoft.com/pubcalstorage/829bhmpz2205324/Календарь_-_Test.ics

(URL contains russian symbols)

 

any ideas?

 

great thx for good gadget ;)

 

Coordinator
Mar 6, 2011 at 1:32 AM

Hi, the problem are the unicode characters in your url. Try to use encoded one: webcals://calendars.office.microsoft.com/pubcalstorage/829bhmpz2205324/%D0%9A%D0%B0%D0%BB%D0%B5%D0%BD%D0%B4%D0%B0%D1%80%D1%8C_-_Test.ics

You can encode your urls yourself or wait for a new release where the encoding will be done automatically. This page would be helpful in case you want to encode your urls: http://www.barelyfitz.com/projects/encoder/ (choose encodeURI and click to encode).

Thanks for pointing out this issue

Zbynek

Mar 6, 2011 at 3:53 AM

Great support ... too fast ))) tnx

I thought so, (but not checked) ... i still get same error and still can open it in Outlook also by encoded URL. Problem is that Outlook generates URL by itself and inserts some russian characters even Calendar itself does not contain russian symbols.

In this example Calendar called simply Test, but Outlook generate something like this ...Kalendar_-_Test.ics and i can't find where i can change this "pattern"

Mar 6, 2011 at 4:01 AM
Edited Mar 6, 2011 at 4:08 AM

I've read some help from Microsoft and noticed some interesting moment

http://office.microsoft.com/en-us/outlook-help/manage-and-preview-calendars-published-with-the-outlook-calendar-publishing-service-HA010388759.aspx

 in step 7 " If the calendar does not appear, make sure that you changed the URL prefix from webcals:// to webcal:// in step 6."

 

I've tried both variants in Outlook and in Gadget - with webcal:// in Outlook does not work ... in Gadget nothing changes

Also I've tried to open (in Gadget) calendar from Windows Live - works perfect.

Coordinator
Mar 6, 2011 at 7:44 AM

Hm, it works for me well... Maybe there is another issue in the current version. In fact I've fixed some bugs relevant to Outlook calendars but these are not officially published yet. You can try to download the latest vesion from the source control or contact me through codeplex contact form and I'll attach the latest build to my reply.

Mar 6, 2011 at 11:09 AM

The reason was in older version of gadget. Now works w/o any problems!!! Great THX!!!

Coordinator
Mar 6, 2011 at 11:34 AM

Glad it is all right now :) Thanks for collaboration